SOLVED: Trying to change from index.php by using .htaccess

SOLVED: Trying to change from index.php by using .htaccess

I tried changing the .htaccess file to include the fix specified to get the old URL's with index.php to redirect.

RewriteRule ^index\.php/(.*)$ http://formguide.cyberhorse.com.au/$1 [R=301,L]

This does not work. However i am getting a lot of error log messages saying -
client denied by server configuration: /home/formguid/public_html/.html

I'm thinking that the index.php redirects are being transformed into .html which is then rejected by Apache.

What can I do to fix this?

cyberhorse
New User
ranks
useravatar
Offline
3 Posts
Administrator has disabled public posting

Re: SOLVED: Trying to change from index.php by using .htaccess

Hello cyberhorse,

Are you using a default joomla .htaccess file ?

Rgds

* Please note that all support is handled on this forum.
** Please read the FAQs and Documentation before posting:
Docs: Advanced Search | JCal Pro® | Josetta | RSVP | sh404SEF®
FAQs: Advanced Search | JCal Pro® | Josetta | RSVP | sh404SEF®

jimie
jimie
Support Specialist
ranks
useravatar
Offline
22226 Posts
Administrator has disabled public posting

Re: SOLVED: Trying to change from index.php by using .htaccess

Yes I am. I downloaded the 1.5.23 version as the one I had was from 1.5.22. I cannot find a complete sample .htaccess file anywhere on Anything Digital so I don't know where the Redirect should be inserted. It it after the Joomla SEO code or before? Should the Joomla SEO redirects be disabled?

cyberhorse
New User
ranks
useravatar
Offline
3 Posts
Administrator has disabled public posting

Re: SOLVED: Trying to change from index.php by using .htaccess

Hello cyberhorse,

That custom htaccess code need to be inserted in the .htaccess file inside your joomla root directory, you can put the code at the end of the file. You dont find a htaccess sample in here because sh404sef uses default joomla htaccess file.

Rgds

* Please note that all support is handled on this forum.
** Please read the FAQs and Documentation before posting:
Docs: Advanced Search | JCal Pro® | Josetta | RSVP | sh404SEF®
FAQs: Advanced Search | JCal Pro® | Josetta | RSVP | sh404SEF®

jimie
jimie
Support Specialist
ranks
useravatar
Offline
22226 Posts
Administrator has disabled public posting

Re: SOLVED: Trying to change from index.php by using .htaccess

OK it worked when I put the index.php Redirect after the Joomla SEO code.

One other thing was I found it necessary to switch off and clear the sh404sef cache in the components folder.

There were some old URL's which would not behave themselves.

Does it make any difference if the native Joomla SEO is turned on or off in System Configuration? Maybe sh404sef overrides that setting.

cyberhorse
New User
ranks
useravatar
Offline
3 Posts
Administrator has disabled public posting

Re: SOLVED: Trying to change from index.php by using .htaccess

Hello cyberhorse,

I`m glad that you fixed your problem, you simply can ignore options for Joomla sef from "Global Configuration" sh404sef does not use them.


OK. Marking solved, and remember:

If you use sh404SEF, please post a rating and a review at the Joomla! Extensions Directory.

http://extensions.joomla.org/extensions … 134/review (login required)

Rgds

* Please note that all support is handled on this forum.
** Please read the FAQs and Documentation before posting:
Docs: Advanced Search | JCal Pro® | Josetta | RSVP | sh404SEF®
FAQs: Advanced Search | JCal Pro® | Josetta | RSVP | sh404SEF®

jimie
jimie
Support Specialist
ranks
useravatar
Offline
22226 Posts
Administrator has disabled public posting

Forum Legend

 

 Topic
 New
 Locked
 Sticky
 Active
 New/Active
 New/Locked
 New Sticky
 Locked/Active
 Active/Sticky
 Sticky/Locked
 Sticky/Active/Locked
 
 

Get the latest updates on our extensions