Joomla 1.6 End of Life - urgent upgrade required

Joomla 1.6 will reach end-of-life on August 19, 2011 and all users should upgrade to version 1.7 before that date.

Version 1.7.0 was released to the public yesterday and includes an important fix for a cross-site scripting vulnerability in Joomla 1.6, underscoring the urgency of upgrading. 

Upgrading from Joomla 1.6.5 to 1.7.0 (and future versions) is now a simple 1-click task built right into the Joomla core. We recommend that all Joomla 1.6 users use this quick and simple method. Please note that this upgrade path is specific for Joomla 1.6.5 ONLY.

In addition to security enhancements and 1-click upgrades, Joomla 1.7 contains a number of feature enhancements including better form validation, batch processing of articles and an improved ability to restrict article submission to specific categories.

Full details can be found on the official announcement at

Are my extensions compatible with Joomla 1.7?

Most templates and extensions compatible with Joomla 1.6 will work in Joomla 1.7. However, you don’t want to leave anything to chance when upgrading. To be sure, check the Joomla Extensions Directory for compatible versions.

For example, sh404SEF® 3.x is Joomla 1.7 compatible as you can see by the new JED icon: Joomla! 1.7 native compatibility

Last modified on Jul202011
blog comments powered by Disqus

Get the latest updates on our extensions